Обновление с ЛС 1.0.1 до 1.0.2

FAQ
Хочу указать на важный аспект, который некоторые пользователи не учли: при установке новой версии ливстрит 1.0.2 поверх 1.0.1 нужно, как и указано при установке, скопировать поверх файлы, оставив только папку с шаблонами (они не менялись) и конфиг. Вот тут пользователи делают маленькую ошибку, суть которой сводится, например, иногда к неработающей регистрации на сайте.

Дело в том, что по идеологии ЛС все правки в конфиг нужно вносить не в главный конфигурационный файл движка config.php, а в config.local.php, потому что config.php может меняться от версии к версии.

Новички, которые не следуют этому указанию и внося изменения прямо в config.php, обычно при обновлении движка и не перезаписывают этот файл, что влечет за собою разного рода ошибки. Например, одна из таких ошибок — неработающая регистрация на сайте, т.к. в 1.0.2 версии движка появилась возможность задавать набор разрешенных символов для логинов пользователей. И если забыть скопировать новый config.php поверх старого, то ни один пользователь не сможет зарегистрироваться на сайте.
0 комментариев
Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.